如何修复Windows上Following Components Are Required错误

如何修复Windows上Following Components Are Required错误

一些用户在软件(或游戏)支持论坛上发布了一条错误消息,上面写着“运行此程序需要以下组件”。 错误消息还指定该组件是 Visual C++ 或 DirectX Runtime。

当用户尝试启动 Windows 游戏时通常会发生此错误。 因此,玩家无法玩出现“Following Components Are Required需要以下组件”错误的游戏。 这是修复 Windows 10 或 11 PC 上的“需要以下组件”错误的方法。

推荐:如何修复Windows上System Call Failed错误

1. 检查并安装任何待处理的 Windows 更新

检查更新选项

首先,尝试检查并安装所有待处理的 Windows 补丁更新。 这是因为某些更新将修复 DirectX,因此如果错误消息指出 DirectX 是罪魁祸首,这将有望解决问题。

查看如何手动更新 Windows 并确保您的电脑处于最新版本。

2. 修复 PC 上的 Visual C++ 包

“需要以下组件”错误通常抱怨缺少 Visual C++ 或 DirectX 运行时。 如果它指定缺少 Visual C++ 运行时,您可能需要修复 PC 的 Visual C++ 版本。

因此,请尝试修复 PC 上已安装的 Visual C++ 软件包,如下所示:

  1. Win + I  打开设置。
  2. 选择 Apps 应用 类别或选项卡并单击 Apps & Features  应用程序和功能 从那里。
  3. 点击 三点按钮 在错误消息中指定的 Visual C++ 包版本旁边,然后选择 Modify调整。 在 Windows 10 中,您需要选择 Visual C++ 包并单击 Modify调整
    修改选项
  4. 选择 Repair 维修 打开的 Visual C++ 窗口中的选项。
    修复选项

3. 安装 2015-2022 Visual Studio C++ 软件包

如果修复不起作用,或者找不到错误中指定的 Visual C++ 包,则可能需要安装缺少的 C++ 运行时库。 Microsoft 有一个网页,您可以从中下载许多不同的 C++ Redistributable 软件包。

尝试从 Visual Studio 2015-2022 包下载并安装 C++ 运行时,如下所示:

  1. 打开此 Visual C++ Redistributable 页面。
  2. 然后单击 Visual Studio 2015-2022 的 X64(64 位)架构下载链接。
    Visual Studio 2015-2022 的 x64 下载链接
  3. 点击  agree  我同意 > Install安装 在 Microsoft Visual C++ 2015-2022 窗口中。
    Visual C++ 的安装选项
  4. 重复第二步和第三步下载并安装 32 位版本的 Visual Studio 2015-2022。 为此,您需要单击 Visual Studio 2015-2022 的 X86 下载链接。

4.安装DirectX运行时库

如果错误消息提到 DirectX,则意味着您的电脑可能缺少游戏所需的 DirectX 运行时组件。 如果您尝试在 Windows 11/10 PC 上玩较旧的游戏,则更有可能出现这种情况。

在这种情况下,请尝试使用 DirectX 最终用户运行时 Web 安装程序安装缺少的旧版 DirectX 运行时库,如下所示:

  1. 打开此 DirectX 安装程序网页并将文件下载到您的电脑。
  2. 接下来,双击 dxwebsetup.exe
  3. 选择 I accept the agreement 我接受此协议 在“安装 Microsoft DirectX”窗口中。
    我接受协议单选按钮
  4. 点击 Next 下一个 继续接受安装 Bing Bar 的报价。
  5. 取消选中 Install the Bing Bar 安装 Bing 栏 如果您不需要该软件,请选中该复选框。
    安装 Bing Bar 复选框
  6. 选择 Next 下一个 安装所需的 DirectX 组件。

5.修复.NET Framework组件

修复选项

用户已确认他们通过重新安装 .NET Framework 组件修复了“需要以下组件”错误。 因此,您可能需要修复 PC 上的 .NET Framework 组件以解决“需要以下组件”错误。

查看如何修复 .NET Framework 以获取更多信息。

6. 在游戏启动器中验证受影响的游戏

验证选项

一些用户表示验证游戏文件可以修复“需要以下组件”错误。 仅当您使用大型游戏启动器应用程序之一(例如 Steam、Epic Games、EA Desktop 和 Origin)购买并下载游戏时,才可以执行此步骤。

如果您不确定如何执行此操作,请查看如何修复不同启动器上的游戏文件。

7. 重新安装受影响的游戏或软件

如果应用上述所有修复后“需要以下组件”问题仍然存在,则重新安装游戏或软件是最后一件事。 有些玩家可能担心重新安装游戏后会丢失已保存的游戏数据。 但是,您可以在以不同方式卸载游戏之前备份已保存的游戏进度。

重新安装此错误影响的游戏或任何其他软件值得一试,因为这将恢复任何丢失的文件。 您可以通过卸载一些游戏 程序和特点 正如我们的 Windows 软件卸载指南中所述。 如果您没有看到那里列出的游戏,您可能需要通过其客户端软件(例如 Epic Games)卸载它。

程序和功能小程序

然后从官方网站下载最新版本的游戏并重新安装。 如果与 Steam 或 Epic 或其他启动器软件一起安装,您需要选择通过其游戏客户端重新安装游戏。 或者从 Microsoft Store 页面重新安装游戏(如果您是在该页面购买游戏的)。

另请注意,一些玩家已经能够通过重新安装 Steam 来解决“需要以下组件”错误。 因此,如果您需要解决 Steam 游戏的此问题,重新安装客户端软件可能值得一试。

再次启动您的 Windows 游戏

许多用户需要修复“需要以下组件”错误,他们通过应用上面列出的潜在解决方案来做到这一点。 因此,这些潜在解决方案中至少有一种可能会启动受影响的 Windows 游戏。

但是,我们不能保证这些潜在的解决方案将始终修复“需要以下组件”错误。 检查受影响的游戏是否有技术支持服务,如果需要,您可以联系以获取进一步的故障排除指导。 如果新游戏出现此错误,请考虑在还可以的情况下申请退款。

推荐:如何禁用Windows搜索服务


Claude、Netflix、Midjourney、ChatGPT Plus、PS、Disney、Youtube、Office 365、多邻国Plus账号购买,ChatGPT API购买,优惠码XDBK,用户购买的时候输入优惠码可以打95折

Chatgpt Plus

发表评论