Amazon Linux 2023上安装EPEL repo

Amazon Linux 2023上安装EPEL repo

Amazon Linux 2023 是 Amazon Linux 2 用户的最新升级版本。但是,用户无法直接从 AWS Linux 2 升级到 AL2023,这意味着他们要么选择全新安装,要么切换到其他 Linux。

但是,我个人认为人们不应该再次选择 AWS Linux 2023,而是必须寻找其他选项,例如 AlmaLinux、Rocky 或 Ubuntu。

我之所以这么说是因为 Amazon Linux 2023 基于 Fedora 但并非所有软件包都可通过其存储库安装在 Fedora 上。相反,AWS 开发人员只会提供具有长期支持的稳定软件包。

听起来不错!对吧?但前提是你想要一个稳定的操作系统,其中包含可通过亚马逊系统存储库获得的软件包,但这并不适合所有人,因为你会错过一些东西,比如 EPEL。

推荐:多用途WooCommerce WordPress主题Uomo 

什么是 EPEL?

我们都知道 EPEL 代表企业 Linux 的额外软件包,它基本上是一个社区驱动的存储库,而不是 RedHat 官方的。这就是为什么 RHEL 和其他基于它的 Linux 操作系统(如 AlmaLinux 和 Rocky Linux)不会默认启用 EPEL。

使用 EPEL 的目的是获取无法通过 RHEL 的 BaseOS 和 Appstream 存储库获取的附加软件包。Fedora 项目维护 EPEL 存储库,旨在与 CentOS、Oracle Linux 和 Amazon Linux 2 等基于 RHEL 的主要发行版兼容。

EPEL 的软件包通常由志愿者维护,涵盖各种类别,包括开发工具、库、服务器应用程序、实用程序等。此存储库遵循严格的准则,以确保所含软件包与基本发行版的稳定性、安全性和兼容性。它受到许多用户、系统管理员和组织的信任,是其基于 RHEL 的系统的可靠补充软件包来源。

Amazon Linux 2023上安装EPEL repo

我们可以在 Amazon Linux 2023 上安装 EPEL 吗?

答案是 ,我们不能添加 EPEL 存储库 在最新的 亚马逊Linux 2023 因为与 A 不同马松Linux 2 基于 CentOS 7 并且与其软件包具有高度兼容性,而 AWS 2023 Linux 却不具备这种兼容性。尽管 AL2023 基于上游 Fedora Linux 发行版以及来自其他非 Fedora Linux 上游的其他特定软件包(例如内核),但 AL2023 与 Redhat 的所有软件包兼容,因此, AL2023 不支持 EPEL 或类似 EPEL 的存储库,我们无法添加它们。

此外,AL2023 也没有“Amazon-extra-packages”。相反,语言运行时等高级软件包将由 Amazon 开发人员作为主要/次要软件包更新提供。此外,您不需要这样做,因为通过它提供的所有软件包都可以使用 AL2023 系统存储库直接安装。

因此,如果您的项目高度依赖 EPEL,那么建议使用 Alamlinux、Rocky 或 Oracle。或者,您可以直接下载并安装所需的 RPM 包,这些包可通过

推荐:WordPress内链插件Interlinks Manager插件


Claude、Netflix、Midjourney、ChatGPT Plus、PS、Disney、Youtube、Office 365、多邻国Plus账号购买,ChatGPT API购买,优惠码XDBK,用户购买的时候输入优惠码可以打95折

Chatgpt Plus

发表评论